News & Research

Company News

Company News

Dear Client / Trader

We would like to inform you that Metaquotes, Forex trading platform developer, announced that MetaTrader 4/5(MT4/5) and all their components will no longer support Windows XP, Windows 2003 and Windows Vista after 01 October 2017.

Older versions of MT4/MT5 will continue to work on these systems, but will not be able to receive updates after 01 October 2017.
Also, installers will not run on these operating systems.

The minimum required operating system version for running MT4/MT5 will be Windows 7 but Metaquotes strongly recommends using 64-bit versions of
Windows 10.

If you have any questions or concerns, please let us know.

Best Regards,
Land-FX Account Team.